Back to overview
Resolved
Downtime reported
Sep 11, 2025 at 9:25am UTC
Affected services
Cloud
Resolved
Sep 12, 2025 at 8:03am UTC
Incident solved, urgent updates scheduled for the next maintenance session
Affected services
Created
Sep 11, 2025 at 9:25am UTC
Currently under investigation, eta: the end of the day.
Affected services