Back to overview
Degraded
Currently experiencing issues
Sep 18 at 12:56am CEST
Affected services
Cloud
Resolved
Sep 20 at 11:53am CEST
Actually working, systems restored
Affected services
Created
Sep 18 at 12:56am CEST
Investigations and fixes are ongoing. Service could become unavailable unpredictably
Affected services